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Scheduling validation issues troubleshooting

Updated over a week ago

S-096-V3-EN

In this article, we go over some of the most common scheduling validation issues and offer solutions.

Deadhead generator

Issue

“Deadhead generated” message in the validation panel.

Probable cause

The deadheads were generated in the optimization process.

Solution

  • If you think the deadhead is valid, save it to the catalog. To learn how to do that, see this article.

  • If the deadhead is not correct, it can be deleted: just click on the deadhead and click the trash bin icon. Keep in mind that it will affect further optimization.

Pre/Post-trip

Issue

The validation panel indicates a per/post-trip-related issue.

Solution

This can be solved by revising pre- and post-trip events:

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Check the Pre / post trips box and click Modify Schedule.

When you have finished fixing or dismissing issues, click on the Validate button at the bottom of the screen next to the validation panel. Then, open the validation panel again to make sure that the issue is not there anymore.

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Stops

Issue

Stops are too Far

The validation indicates that there is no link between two joining pieces of work.
For example, the first piece finishes at ‘'Ship Hotel'’ and the joining trip starts at ‘'Elmsleigh Station'’.

Probable Root Causes:

There may be a few reasons why the system cannot link the two trips. Please follow the step-by-step guide below to help identify and resolve the issue.

Missing Travel/Walk

  1. Lock all duties except for the ones that show this validation error.

  2. Revise events - Travels.

  3. Add travel to the catalogue, if needed.

Missing deadhead in Vehicle Schedule

  1. If needed, add the appropriate deadhead between the pieces within the Vehicles.

  2. If needed, add deadheads to the catalogue.

Stops have not been ‘'Place grouped’' in the Stop Catalogue

While in planning, if two stops are located in the same place but have different stop IDs, you can place group them. For example Bus station bays. This allows grouping different stops that are in the same location—also known as a master or parent stop.

  1. Export the Stop catalogue from Timeplan

  2. Filter for relevant stops

  3. Paste the ID from the Parent stop into the 'PLACE' column of the Child stop row. The Parent stop should be the main stop you want to use as the focal point.

If Stops have been place grouped, make sure the deadheads or travels are using the ID of the Parent stop, and that the correct stops have been grouped together.

Preferences issues

Issue

“Layover - after route”:

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Probable cause

There is a conflict with one of the preferences you have set in the schedule.

Solution

Click on the IDs with the red exclamation mark to see what the issue is.

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You can either ignore it if you know there is no actual issue, change your preferences to accommodate this issue, or manually edit these trips by clicking on the pencil icon at the top.

Issue

“Pref group - route groups #”

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Probable cause

A duty assigned to the preference group is currently doing at least one trip of a route that is not allowed.

Solution

Enable the Preference group stat and see if the duty is assigned to the correct preference group.

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If it is correct, make sure all routes within the duty are under the corresponding route group.

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If all of the above is correct, check the Pref Group - Route Group template within Custom duty preferences to make sure the correct route group is linked to the correct preference group.

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Note: If Custom work is added to a duty, you will need the Pref Group - Route group + custom work template.

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