Skip to main content

Duty travel troubleshooting

Updated over 2 weeks ago

S-152-V2-EN

Duty travel preferences allow you to define how drivers can travel between stops while not driving. This could either be a walk, a trip as a passenger on another service bus, or using a relief car.

Below you will find some common errors that can occur with duty travel and how to fix them.

Travel event is not in the catalog

This can occur with Walk and Relief car events. For both of those, you will see an error in the validation panel.

Solution

Check the following:

  1. Make sure the stop IDs you need the event from and to are defined in the catalog correctly. Also, make sure the time and distance are filled in.

  2. If you’ve assigned days of the week to an event in the catalog make sure it covers the service ID you’re working on.

  3. If you’ve filled in the start and end time ranges, make sure they cover the time you’re trying to add a travel for.

  4. If you have defined purposes for the events, make sure these cover the purpose you’re trying to add an event for.

More information on how to correctly set up a travel catalog can be found in this article.

Stops are too far

This issue can occur with Walk and Relief car events. For both of these, you will see an error in the validation panel.

Probable cause

This error points to a driver getting off a bus at one stop and back on a bus at another stop when those stops are not place-grouped and there is no travel between them.

Solution

Try to add a travel between the stops. If you get an event with a red border and a default time of 5 minutes, the event cannot be added from the catalog. Follow the steps in the Travel not in the catalog section above to see how this can be added.

Public transport event cannot be added

Probable cause

The main cause for this validation error is that there are no valid trips available for use as Public Transportation (PT) at the requested time. Either the required stops have not been marked as Relief points in Planning or there may be other travel events such as walks that are from the travel catalog.

Solution

Try the following solutions:

  • Check that the route in question is allowed for PT travel in the Duty Travel preferences:

    image.png


  • Make sure that the stops that will be used for PT travel have been marked as relief points in Planning.

  • Try to manually add the duty as a passenger on the trip you would want them to take.

    • If they only need to travel for part of the trip, click the trip and click Ungroup.

    • “Cut” the trip so you’re left with the section you want the duty to travel on. Note this is only to add a passenger and does not affect the trip other than that.

      image.png

    • Right-click the section and click Add Passenger. You can then move that trip on the duty driver you want to be the passenger.

  • This error could point to a couple of other issues. If the public transport travel goes on the duty with no walks, follow the Travel not in catalog section above to troubleshoot this. If you’re using the Purpose field in the catalog, make sure you have a line for Combination.

  • You could get an error pointing to a buffer time being broken. If this is the case, check the buffer time section in the Public Transportation section of the Duty Travel preference to ensure the trip you’ve selected has enough time before and after it, and does not break the max wait time.

Did this answer your question?